What do you need help with?


If you received an install error about not being able to install mandatory prerequisites, please do the following:

1) If you are on a 32 bit machine, uninstall duet and get the latest from http://duetdisplay.com/windows and it should fix your issue

2) If not, please contact us and we can walk you through the issue.

Was this article helpful?

  • Contact Us